soarli

解决Ubuntu下因依赖包而无法安装问题
情景一(不一致的版本正要被安装):有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是 因为系...
扫描右侧二维码阅读全文
25
2020/01

解决Ubuntu下因依赖包而无法安装问题

情景一(不一致的版本正要被安装):

有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
 vim : 依赖: vim-common (= 2:7.4.826-1ubuntu1) 但是 2:7.4.1689-3ubuntu1 正要被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。

解决方案:

输入下面命令

sudo apt-get remove vim-common

把未满足的依赖关系移除就不会报错了

情景二(依赖关系将不会被安装):

有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
 libclang-dev : 依赖: libclang-3.6-dev (>= 3.6~rc1) 但是它将不会被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。

解决方案:

安装aptitude

sudo apt-get install aptitude

再安装

sudo aptitude install libclang-dev

命令执行效果:

下列“新”软件包将被安装。         
  libclang-3.6-dev{a} libclang-common-3.6-dev{a} libclang-dev 
  libclang1-3.6{a} libllvm3.6v5{a} libobjc-5-dev{ab} libobjc4{ab} 
0 个软件包被升级,新安装 7 个, 0 个将被删除, 同时 0 个将不升级。
需要获取 24.0 MB 的存档。 解包后将要使用 169 MB。
下列软件包存在未满足的依赖关系:
 libobjc4 : 依赖: gcc-5-base (= 5.3.1-5ubuntu1) 但是 5.3.1-14ubuntu2 已安装。
 libobjc-5-dev : 依赖: gcc-5-base (= 5.3.1-5ubuntu1) 但是 5.3.1-14ubuntu2 已安装。
                 依赖: libgcc-5-dev (= 5.3.1-5ubuntu1) 但是 5.3.1-14ubuntu2 已安装。
下列动作将解决这些依赖关系:

     保持 下列软件包于其当前版本:
1)     libclang-3.6-dev [未安装的]
2)     libclang-dev [未安装的]    
3)     libclang1-3.6 [未安装的]   
4)     libobjc-5-dev [未安装的]   
5)     libobjc4 [未安装的]        



是否接受该解决方案?[Y/n/q/?] n
下列动作将解决这些依赖关系:

      降级 下列软件包:                                                   
1)      cpp-5 [5.3.1-14ubuntu2 (now) -> 5.3.1-5ubuntu1 (xenial)]          
2)      g++-5 [5.3.1-14ubuntu2 (now) -> 5.3.1-5ubuntu1 (xenial)]          
3)      gcc-5 [5.3.1-14ubuntu2 (now) -> 5.3.1-5ubuntu1 (xenial)]          
4)      gcc-5-base [5.3.1-14ubuntu2 (now) -> 5.3.1-5ubuntu1 (xenial)]     
5)      libasan2 [5.3.1-14ubuntu2 (now) -> 5.3.1-5ubuntu1 (xenial)]       
6)      libatomic1 [5.3.1-14ubuntu2 (now) -> 5.3.1-5ubuntu1 (xenial)]     
7)      libcc1-0 [5.3.1-14ubuntu2 (now) -> 5.3.1-5ubuntu1 (xenial)]       
8)      libcilkrts5 [5.3.1-14ubuntu2 (now) -> 5.3.1-5ubuntu1 (xenial)]    
9)      libgcc-5-dev [5.3.1-14ubuntu2 (now) -> 5.3.1-5ubuntu1 (xenial)]   
10)     libgomp1 [5.3.1-14ubuntu2 (now) -> 5.3.1-5ubuntu1 (xenial)]       
11)     libitm1 [5.3.1-14ubuntu2 (now) -> 5.3.1-5ubuntu1 (xenial)]        
12)     liblsan0 [5.3.1-14ubuntu2 (now) -> 5.3.1-5ubuntu1 (xenial)]       
13)     libmpx0 [5.3.1-14ubuntu2 (now) -> 5.3.1-5ubuntu1 (xenial)]        
14)     libquadmath0 [5.3.1-14ubuntu2 (now) -> 5.3.1-5ubuntu1 (xenial)]   
15)     libstdc++-5-dev [5.3.1-14ubuntu2 (now) -> 5.3.1-5ubuntu1 (xenial)]
16)     libstdc++6 [5.3.1-14ubuntu2 (now) -> 5.3.1-5ubuntu1 (xenial)]     
17)     libtsan0 [5.3.1-14ubuntu2 (now) -> 5.3.1-5ubuntu1 (xenial)]       
18)     libubsan0 [5.3.1-14ubuntu2 (now) -> 5.3.1-5ubuntu1 (xenial)]      



是否接受该解决方案?[Y/n/q/?] y
下列软件包将被“降级”:
  cpp-5 g++-5 gcc-5 gcc-5-base libasan2 libatomic1 libcc1-0 libcilkrts5 
  libgcc-5-dev libgomp1 libitm1 liblsan0 libmpx0 libquadmath0 
  libstdc++-5-dev libstdc++6 libtsan0 libubsan0 
下列“新”软件包将被安装。
  libclang-3.6-dev{a} libclang-common-3.6-dev{a} libclang-dev 
  libclang1-3.6{a} libllvm3.6v5{a} libobjc-5-dev{a} libobjc4{a} 
0 个软件包被升级,新安装 7 个, 18 个被降级, 0 个将被删除, 同时 0 个将不升级。
需要获取 122 MB 的存档。 解包后将要使用 523 MB。
您要继续吗?[Y/n/?] y

备选方案:更换软件源(貌似更擅长解决情景一)

源地址大全(官方):
https://wiki.ubuntu.org.cn/%E5%A6%82%E4%BD%95%E4%BD%BF%E7%94%A8%E6%88%91%E4%BB%AC%E6%8E%A8%E8%8D%90%E7%9A%84%E6%BA%90

阿里云源对于18.04版本的地址:

http://mirrors.aliyun.com/ubuntu/

打开本地源配置文件:

sudo gedit /etc/apt/sources.list

换上合理的软件源后,再刷新一下,注意一定要刷新,运行:

sudo apt-get update

原文地址:
https://blog.csdn.net/weixin_30781631/article/details/99928202

https://blog.csdn.net/wang_yunpeng/article/details/52863517

最后修改:2020 年 04 月 01 日 10 : 16 PM

发表评论